Bevis at den eksisterte, og hold den gyldig lenge etter at sertifikatet utløper
Et C2PA-kompatibelt tidsstempel forankrer signeringsøyeblikket kryptografisk, uavhengig av sertifikatets livssyklus. Innholdets opprinnelse forblir verifiserbar på lang sikt.
Pålitelig, uavhengig bevis på at et C2PA-manifest eksisterte på et gitt tidspunkt
En tidsstemplingsinstans er en pålitelig tredjepart som på forespørsel kryptografisk signerer hashen av dataene dine sammen med gjeldende tidspunkt hentet fra en pålitelig, revidert tidskilde. Resultatet er et tidsstempeltoken som beviser at dataene eksisterte i nøyaktig den formen på det tidspunktet, og ikke har endret seg med en eneste bit siden.
Klienten sender aldri det faktiske innholdet. Bare en hash (meldingsdigest) sendes, så TSA ser aldri dataene dine. I henhold til RFC 3161 sender forespørselen inn en TimeStampReq som inneholder meldingsavtrykket, og TSA returnerer en signert TimeStampToken som kan verifiseres uavhengig og revideres på et hvilket som helst fremtidig tidspunkt.
I C2PA er dette viktig fordi manifesterer uten Et klarert tidsstempel opphører å være gyldig i det øyeblikket signeringslegitimasjonen utløper eller tilbakekalles. Med et tidsstempel innebygd som en kontrasignatur kan en validator bekrefte at kravet ble signert mens legitimasjonen var gyldig, og fortsette å stole på den på ubestemt tid.
Hovedfordeler
Langsiktig validering (LTV)
Et klarert tidsstempel lar en C2PA-kravsignatur forbli gyldig på ubestemt tid, selv etter at signeringssertifikatet utløper eller er tilbakekalt. Viktig for C2PA-manifester som er ment å vare.
C2PA-kompatibel
Hvis du vil at C2PA-validatorer skal validere tidsstemplene dine, trenger du en C2PA-tidsstemplingsinstans som er akkreditert på C2PA TSAs tillitsliste. SSL.com var den første WebTrust-reviderte CA-en som ble lagt til på tillitslisten.
Dataene dine forlater aldri miljøet ditt
Bare hashen sendes. TSA tidsstempler meldingsavtrykket og ser aldri det underliggende innholdet.
Pålitelig, revidert tidskilde
Tid hentes fra en pålitelig kilde og signeres med nøkler som holdes i HSM-er under SSL.coms reviderte drift.
API-drevet og skalerbar
Høyvolums RFC 3161 API for automatiserte C2PA-signeringsrørledninger, fra en håndfull eiendeler til milliarder.
SSL.coms tidsstemplingsmyndighet brukes av…
C2PA-kravgeneratorer og -plattformer
Integrering av pålitelige tidsstempler slik at innholdslegitimasjon overlever sertifikatutløp.
Kamera- og enhetsprodusenter
Legge ved bevis på eksistens ved opptak, eller kort tid etter, på server- eller appsiden.
Innholdsskapere og AI-medieplattformer
Tidsstempling av generert innhold for å holde opprinnelsen verifiserbar på lang sikt.
C2PA-kompatible produkter
Trenger pålitelige tidsstempler for langsiktig manifestvalidering.
Tilgang og priser
Velg hvordan du bruker TSA.
C2PA gratis nivå-sertifikat
2,500 tidsstempler per år inkludert med et gratis C2PA-sertifikat på nivå 1. Ekstra tidsstempler kan bestilles på forespørsel eller i bulk.
Søk om gratisnivåetC2PA Premium Tier-sertifikat
10 000 tidsstempler per år inkludert i et premium C2PA-sertifikat. Ekstra tidsstempler kan bestilles på forespørsel eller i bulk.
Kjøp et premium C2PA-sertifikatStorskala bulkrater
Kjøp så mange tidsstempler som nødvendig til en redusert bulkpris i stor skala.
Kontakt salg- Sikker, autentisert API-tilgang
- Spørsmål? Chat med en ekspert på innholdsautentisitet
- Trenger du priser for store volumer eller bedrifter? Etterspør et sitat
Hvordan fungerer det
1. Hash dataene dine
C2PA-kravgeneratoren din beregner COSE ToBeSigned-verdien med CounterSignature-konteksten.
2. Be om et tidsstempel
Klienten din sender en RFC 3161 TimeStampReq til SSL.com TSA-endepunktet (RSA eller ECC). Bare hashen overføres.
3. TSA signerer tiden
SSL.com binder hashen din til en pålitelig tidsverdi og signerer den med en HSM-beskyttet nøkkel, og returnerer en TimeStampToken.
4. Legg inn tokenet
Bygg inn tidsstempelet i C2PA-kravsignaturen (for eksempel med C2PA-RS) som en kontrasignatur i COSE_Sign1-strukturen.
5. Valider på ubestemt tid
Enhver kompatibel C2PA-validator kan bekrefte tidsstempelet mot SSL.coms pålitelige TSA-sertifikat, og bevise at kravet ble signert mens legitimasjonen var gyldig, nå og i fremtiden.
API-sluttpunkt
| Endpoint | API-nøkkel | Tekniske beskrivelser |
|---|---|---|
https://ts-c2pa.ssl.com | Påkrevd | C2PA-kompatibel RFC 3161 Time Stamping Authority API med ECC (RSA tilgjengelig på forespørsel) |
Samsvar og standarder
| standard | Relevans |
|---|---|
| RFC 3161 (tidsstempelprotokoll) | Vår TSA er i samsvar med IETF X.509 Time-Stamp Protocol som dekker forespørsels-/svarformatet og TSAs driftskrav. |
| C2PA-kompatibel TSA | SSL.com er akkreditert på C2PA TSA Trust List. |
| RFC 5816 | ESSCertIDv2-oppdatering av signing-certificate-attributtet som brukes i tidsstempeltokener. |
| Krav til C2PA-medsignatur | Tidsstempler innhentes i henhold til C2PAs tilleggskrav, ved bruk av CounterSignature-konteksten og COSE Sig_structure for meldingsavtrykket. |
| RFC 8152 (COSE) | ToBeSigned-verdien som er tidsstemplet for C2PA, er konstruert i henhold til COSE Sig_structure. |
| WebTrust for CA (BDO) | SSL.coms CA- og TSA-operasjoner revideres årlig under WebTrust-programmer. |
Ofte stilte spørsmål
Uten et klarert tidsstempel slutter et manifest å være gyldig så snart signeringssertifikatet utløper eller tilbakekalles. Et tidsstempel lar en validator bekrefte at kravet ble signert mens legitimasjonen var gyldig, slik at manifestet kan valideres på ubestemt tid.
Det er et spesielt C2PA-manifest som gir bevis på eksistens for et aktivum og manifestet på et pålitelig tidspunkt. Det brukes oftest når en tidligere generator logget frakoblet og ikke kunne hente et tidsstempel ved signering.
Nei. Bare en hash (meldingsavtrykk) sendes til TSA. Det faktiske innholdet forlater aldri miljøet ditt.
Match endepunktet med C2PA-signeringsarbeidsflyten din og algoritmene validatorene dine forventer. Begge er C2PA-kompatible; ECC produserer mindre tokener og er raskere, RSA er tilgjengelig på forespørsel.
Vårt gratis C2PA-nivå inkluderer 2,500 tidsstempler per år, med priser på forespørsel for ekstra volum. Vårt premiumnivå C2PA inkluderer 10 000 tidsstempler per år. Premiumkunder kan kjøpe ekstra volum til redusert bulkpris.
Relaterte produkter
C2PA-kravsigneringssertifikater (gratis og premium)
Signeringssertifikatet hvis kravsignaturer du tidsstempler for langsiktig validering.
Se C2PA-sertifikater